广告位联系
返回顶部

CentOS8 Mysql启动失败问题及解决过程

linux 来源:互联网 作者:佚名 发布时间:2026-10-04 21:32:48 人浏览
摘要

1. 问题描述 启动Mysql失败 1 2 3 4 [root@primo ~]# service mysqld start Starting mysqld (via systemctl): Job for mysqld.service failed because the control process exited with error code. See systemctl status mysqld.service and journalctl -xe f

1. 问题描述

启动Mysql失败

1

2

3

4

[root@primo ~]# service mysqld start

Starting mysqld (via systemctl):  Job for mysqld.service failed because the control process exited with error code.

See "systemctl status mysqld.service" and "journalctl -xe" for details.

[FAILED]

2. 原因分析

查看Mysql日志

1

Can't start server: can't check PID filepath: No such file or directory

原来时Mysql启动时没找到PID filepath,通过命令cd /var/run/进入文件夹,发现没有mysqld文件夹,导致启动失败

3. 解决办法

1. 新建mysqld 文件夹

1

[root@primo run]# mkdir /var/run/mysqld/

2. 修改操作权限

1

[root@primo run]# chown mysql.mysql /var/run/mysqld/

3. 重启mysql,此时可以正常启动了

1

2

[root@primo run]# service mysqld start

Starting mysqld (via systemctl):  [  OK  ]


版权声明 : 本文内容来源于互联网或用户自行发布贡献,该文观点仅代表原作者本人。本站仅提供信息存储空间服务和不拥有所有权,不承担相关法律责任。如发现本站有涉嫌抄袭侵权, 违法违规的内容, 请发送邮件至2530232025#qq.cn(#换@)举报,一经查实,本站将立刻删除。
原文链接 :
相关文章
  • 本站所有内容来源于互联网或用户自行发布,本站仅提供信息存储空间服务,不拥有版权,不承担法律责任。如有侵犯您的权益,请您联系站长处理!
  • Copyright © 2017-2022 F11.CN All Rights Reserved. F11站长开发者网 版权所有 | 苏ICP备2022031554号-1 | 51LA统计